Veda2.0 Released!


BEV: Battery Electric vehicle/Train
#1
Hi,

We are trying to prepare a small model (DEMO) which contains one BEV train. For this train, there are three batteries as NST (STOTTPRELC100D, STOTTPRELC100N, STOTTPRELC100P) and these are suppose to supply the electricity needed for the train.

STOTTPRELC100P- charging at peak time
STOTTPRELC100N- charging at Night time
STOTTPRELC100P - charging at day time

TTPRELC100- battery electric train.

Simplified RES:

CHRELC > STOTTPRELC100P > DISELC > TRAELC01 (convert DISELC into TRAELC) > TRAELC > TTPRELC100 > TTP (Demand)


Unfortunately the model does not work the way it is intended, I mean the batteries does not charge at all, hence model choose to use the Dummy_demand_import processes! As a new user of VEDA, I could not find what we are doing wrong!

I have attached the whole model, as it is small and easy to look at. It would be great if anyone can look into it and let us know what is the solution.

Many Thanks.


Attached Files
.xlsx   VT_REG_PRI_V01_Bahn.xlsx (Size: 545.14 KB / Downloads: 5)
.xlsx   SysSettings.xlsx (Size: 97.88 KB / Downloads: 4)
Reply
#2
I looked at it, and I was easily able to make the model functional.

The dummy imports are a VEDA feature, which can be nasty for beginners. For your model, VEDA added dummy import supply options for all commodities at zero costs. I hope you can imagine that the model can not produce any meaningful results, if the dummy imports can supply everything without any cost.  Such dummy imports serve basically no useful purpose in the model.

So, I disabled all the dummy imports, and ran the model again. There were a few infeasibilities (not related to the storage processes), which I also fixed, and after that the model worked well with respect to those NST storage processes for TTPRELC100 and the TTP demand.  So, my solution was to disable all dummy imports, and then fix the remaining infeasibilities in the model, which CPLEX can point out in the listing file when you use the option names 1 (in cplex.opt) and the OPTION SYSOUT=ON (in the RUN file). I hope that can be of some help.
Reply
#3
Hi Antti-L,

Thank you so much. Storage process worked after disabling the Dummy Imports.
I used bound on Dummy import to disable! Is there any other way to disable the dummy import without using bound?

Thanks in advance!
Reply
#4
You can disable them via the menu - Tools >> User Options >> Sync Options.

Need to re-sync for this to reflect.
[+] 1 user Likes AKanudia's post
Reply
#5
(30-04-2024, 02:53 PM)AKanudia Wrote: You can disable them via the menu - Tools >> User Options >> Sync Options.

Need to re-sync for this to reflect.

Hi,

Thank you for your reply. It was helpful !
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Modeling New Vehicle Technologies eorear86 2 2,451 23-03-2021, 10:20 PM
Last Post: Pernille.S

Forum Jump:


Users browsing this thread: 1 Guest(s)