Veda2.0 Released!


Dummy Imports IMPNRGZ
#1
Hello modellers,

we are facing a problem with dummy imports in an demo electricity model: One region in our model cannot be fed with enough energy, even though there's
- enough capacity installed
- AFA factors have been checked (even set to 1)
- peak factors have been checked (even set to 1)

Two observations:
- When we increase the capacity of the available technologies, IMPNRGZ disappears at some point. However, the available technologies are never being used up to the maximum they could.
- IMPNRGZ appears just in some time slices, but still we think there's a more general problem with the model.

=> Our impression is, that it is not the basic energy balance equation (EQ_ACTFLO to my mind), which is triggering the dummy imports.

Where can we check which equation is violated, hence, where and why the IMPNRGZ technology is brought into live?

Thanks for your help!
fg
Reply
#2
(27-10-2016, 06:17 PM)fg Wrote: Hello modellers,

we are facing a problem with dummy imports in an demo electricity model: One region in our model cannot be fed with enough energy, even though there's
- enough capacity installed
- AFA factors have been checked (even set to 1)
- peak factors have been checked (even set to 1)

Two observations:
- When we increase the capacity of the available technologies, IMPNRGZ disappears at some point. However, the available technologies are never being used up to the maximum they could.
- IMPNRGZ appears just in some time slices, but still we think there's a more general problem with the model.

=> Our impression is, that it is not the basic energy balance equation (EQ_ACTFLO to my mind), which is triggering the dummy imports.

Where can we check which equation is violated, hence, where and why the IMPNRGZ technology is brought into live?

Thanks for your help!
fg

Do you a peak equation in this model?
Maurizio Gargiulo <br />
Reply
#3
(27-10-2016, 07:02 PM)Gargiulo Wrote:
(27-10-2016, 06:17 PM)fg Wrote: Hello modellers,

[...]

Do you a peak equation in this model?

No, we don't have peaking equations yet.
To ensure this, I just set the PEAK value to zero for every technology in the model, which did not have any effect. (At least this behaviour was according to what I was expecting).
Reply
#4
(27-10-2016, 07:45 PM)fg Wrote:
(27-10-2016, 07:02 PM)Gargiulo Wrote:
(27-10-2016, 06:17 PM)fg Wrote: Hello modellers,

[...]

Do you a peak equation in this model?

No, we don't have peaking equations yet.
To ensure this, I just set the PEAK value to zero for every technology in the model, which did not have any effect. (At least this behaviour was according to what I was expecting).

That's something different, the PEAK attribute is used to specify the contribution of a technology to the peak equation. Can you check if in your model there is the COM_PEAK attribute? And/or removing the PEAK value zero what will happen?
Maurizio Gargiulo <br />
Reply
#5
(27-10-2016, 08:02 PM)Gargiulo Wrote:
(27-10-2016, 07:45 PM)fg Wrote:
(27-10-2016, 07:02 PM)Gargiulo Wrote:
(27-10-2016, 06:17 PM)fg Wrote: Hello modellers,

[...]

Do you a peak equation in this model?

No, we don't have peaking equations yet.
To ensure this, I just set the PEAK value to zero for every technology in the model, which did not have any effect. (At least this behaviour was according to what I was expecting).

That's something different, the PEAK attribute is used to specify the contribution of a technology to the peak equation. Can you check if in your model there is the COM_PEAK attribute? And/or removing the PEAK value zero what will happen?

Ok, I just checked and there is no COM_PEAK attribute. (If there was, it should appear in the TIMES view, right?)
The model has just simple energy demands and COM_FR values to represent a load curve...
Reply
#6
(27-10-2016, 08:23 PM)fg Wrote:
(27-10-2016, 08:02 PM)Gargiulo Wrote:
(27-10-2016, 07:45 PM)fg Wrote:
(27-10-2016, 07:02 PM)Gargiulo Wrote:
(27-10-2016, 06:17 PM)fg Wrote: Hello modellers,

[...]

Do you a peak equation in this model?

No, we don't have peaking equations yet.
To ensure this, I just set the PEAK value to zero for every technology in the model, which did not have any effect. (At least this behaviour was according to what I was expecting).

That's something different, the PEAK attribute is used to specify the contribution of a technology to the peak equation. Can you check if in your model there is the COM_PEAK attribute? And/or removing the PEAK value zero what will happen?

Ok, I just checked and there is no COM_PEAK attribute. (If there was, it should appear in the TIMES view, right?)
The model has just simple energy demands and COM_FR values to represent a load curve...

can you share your model for checking?
Maurizio Gargiulo <br />
Reply
#7
(27-10-2016, 08:33 PM)Gargiulo Wrote:
(27-10-2016, 08:23 PM)fg Wrote:
(27-10-2016, 08:02 PM)Gargiulo Wrote:
(27-10-2016, 07:45 PM)fg Wrote:
(27-10-2016, 07:02 PM)Gargiulo Wrote: Do you a peak equation in this model?

No, we don't have peaking equations yet.
To ensure this, I just set the PEAK value to zero for every technology in the model, which did not have any effect. (At least this behaviour was according to what I was expecting).

That's something different, the PEAK attribute is used to specify the contribution of a technology to the peak equation. Can you check if in your model there is the COM_PEAK attribute? And/or removing the PEAK value zero what will happen?

Ok, I just checked and there is no COM_PEAK attribute. (If there was, it should appear in the TIMES view, right?)
The model has just simple energy demands and COM_FR values to represent a load curve...

can you share your model for checking?

Hm, we would rather avoid doing so, as there is already some restricted (=bought) data in the models Undecided

However, me and a colleague just discovered, that the problem is somehow related to the timeslice resolution.
The model consists of 4 seasons each 2 weeklies each 24 hours => 192 timeslices.

Setting all technologies and commodities to ANNUAL or SEASON level, results in only 3 technologies satisfying the demand.
When we set them to WEEKLY level, 5 technologies are being used.
Finally, when we apply DAYNITE level, 9 technologies incl. IMPNRGZ are needed...

What could be the reason for this behaviour? According to our understanding, the aggregated annual results should be the same as the costs do not change with the temporal resolution?!?
Are the timeslices maybe interconnected somehow?
Reply
#8
I've attached the SysSettings.xlsx file - as you can see, the sum of year fractions YRFR equals 1.
Maybe there's some general setting wrong?

Thank you a lot for your help Maurizio!


Attached Files
.xlsx   SysSettings.xlsx (Size: 169.83 KB / Downloads: 15)
Reply
#9
(28-10-2016, 01:31 PM)fg Wrote: I've attached the SysSettings.xlsx file - as you can see, the sum of year fractions YRFR equals 1.
Maybe there's some general setting wrong?

Thank you a lot for your help Maurizio!

Probably the total installed capacity is not enough when you move to the daynite resolution. Might be a short timeslice in which the demand is high and so more capacity is needed compared to the annual/seasonal balance. I already had similar problem in the past and looking at your SysSetting you have a lot of short timeslice.
Maurizio Gargiulo <br />
Reply
#10
Maurizio, thanks for your reply. In the meantime I've been in contact with Amit who also highlighted this capacity issue.
Indeed, you two guys were right, the installed capacties were undersized.

Maybe this helps somebody in the future who is having similar issues:
The load (=required capacity) is calculated in TIMES as:
   Load(s) = Demand(y) * COM_FR(s) / CAP2ACT / YRFR (s)

Is there a way to check the load anywhere in VEDA-BE?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)