Veda2.0 Released!


Import UC troubles
#1
Hello VEDA community! I've been having some troubles getting a UC to work regarding the imports of a commodity. The idea is that I want the imports of this commodity to be limited as a maximum of 34.37% of the total commodity that enters the system (i.e, the sum of the production in the region and the imports) from the starting to the ending year. I have done this as well for exports, establishing in their case a minimum export ratio, and they work perfectly fine, growing accordingly as the demand grows. However, the imports seem to be limited to the value of the BY and remain constant in all the years.

The BY values for both imports (3.26 MT) and exports (2.83 MT), which correspond these ratios, were set in the VT with an BNDACT~UP~2016 (the BY) and a BNDACT~LO~2016 respectively. Then, the following UC were set for both:

   

As you can see in the results, exports are working correctly (they grow as the demand of the IPH commodity does, maintaining the 29.86% ratio), but imports are not, and, instead, are stuck in the BY value.

   

I tried changing the UP limit to FX to see how the model would react and it reached the following infeasibility, which makes me question: where do the first and last variables in conflict come from? They should only be the limits for the BY, not 2050 or any other year, and while the EXPIPH one doesn't conflict with the UC, as it's a LO limit, the IMPIPH one clearly does and might be the source of this problem.

Number of equations in conflict: 2
fixed: EQE_COMBAL('ES',2050,'IPH',ANNUAL) = 8.30544
fixed: EQE_UCRTS('UC_MaxImp_IPH','ES',2050,ANNUAL) = 0

Number of variables in conflict: 4
lower: VAR_ACT('ES',2050,2050,'EXPIPH',ANNUAL) > 2.82942
lower: VAR_COMNET('ES',2050,'IPH',ANNUAL) > 0
fixed: VAR_UCRTS('UC_MaxImp_IPH','ES',2050,ANNUAL) = 0
upper: VAR_ACT('ES',2050,2050,'IMPIPH',ANNUAL) < 3.25592

Thank you all for your time!
Reply
#2
Perhaps you have an IE option generated for the ACT_BND(UP), such that the imports will bounded to at most 3.25592 throughout the model horizon? Just one possibility to check...
Reply
#3
(22-09-2022, 02:30 PM)Antti-L Wrote: Perhaps you have an IE option generated for the ACT_BND(UP), such that the imports will bounded to at most 3.25592 throughout the model horizon?  Just one possibility to check...

Thank you, Antti. I wanted yo show you my current interpolation options, but it seems like my images are not working correctly. Since pasting them in the text box seemed to work in the editing box, I figured it would also do it in the thread. Am I missing something or should I just upload them somewhere and use the function to link the URL?
Reply
#4
Interesting...  I tried myself pasting an image into the text box, both as a bitmap and as a Windows Picture, but both ways failed. Which method (and browser) are you using?

I would indeed also be interested to learn how you can paste an image into the Forum Post textbox. Meanwhile, you can always use the Attachment functionality, which is shown below the text box when editing a post. That's what I have been using, but I agree that a simple paste would be much easier. I guess the Forum Admins should be able to give some additional info on the available options, if they happen to notice your question.
Reply
#5
Dear APERULA,

Please find the attached document. This will guide you how to attach an image to the post.

Do let me know if you need any further help!


Attached Files
.docx   How to attach an Image in forum post.docx (Size: 419.96 KB / Downloads: 2)
Reply
#6
Hello! Thanks to the both of you I was able to properly attach them this time and solve the mess I had made in my first post. Now you should be able to see those images as intended. 

These are my current interpolation options (which I didn't originally set, so I may not be able to answer some questions regarding them):

   

PS: I was able to paste the images using Windows' snipping tool and just ctrl+v them into the text box. In editing mode the images look perfect, but I guess they do not automatically upload and thus trigger the errors. I've been using Chrome.
Reply
#7
Ok, as far as I can see, you have a default interpolation option 5 for ACT_BND(UP), which explains that bound being defined for the full model horizon.

If you don't want that IE option for the ACT_BND of the said import process, just define any desired option for it, in the same template where you define the 2016 bound.
Reply
#8
(23-09-2022, 03:28 PM)Antti-L Wrote: Ok, as far as I can see, you have a default interpolation option 5 for ACT_BND(UP), which explains that bound being defined for the full model horizon.

If you don't want that IE option for the ACT_BND of the said import process, just define any desired option for it, in the same template where you define the 2016 bound.

I didn't know 5 (interpolation and forward extrapolation, right?) forced bounds to be set for the whole horizon. Which interpolation option would you suggest for this purpose? I tried achieving the same result but using INS tables (defining the ACT_BND for each year according to the evolution of the import rate I was looking for) and it worked, but I would like to master UC and the interpolation options as much as I can. Thank you!
Reply
#9
Well, I think 10 should be fine for you. You can define it in an INS table if you like, as long as that scenario comes after SysSettings.  So, instead of defining the evolution with ACT_BND for each year, try defining just the IE option, by specifying Year=0 and value=10.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)