Veda2.0 Released!

Non-optimal results when 'fixed result to x period'
I am trying to use Lodag GDX>'fixed years up to' attribute to run a scenario with a wide range of carbon budgets. I am fixing results to BAU scenario until 2020, so the model will optimize after this period. When I do this, I get 'solution available but not proven optimal due to numerical difficulties'. This happens even in scenarios which the carbon budgets are not that stringent, hence I would expect optimal results.
And the curious thing about (which made me post this here) is that if i fix results up to 2030, not up to 2020, then I reach optimal results. It does not make sense that I get optimal results when I fix results to BAU up to 2030 (hence a lower number of periods to invest on mitigation), but not when I fix results to BAU up to 2020.
Would anyone have a hint on what is happening and how to fix this?
Well, if you fix results up to 2030, then you have a smaller model, which is thus easier to solve than when you fix up to 2020.  So, to me it does make sense that you then reach proven optimal results.  Blush

Anyway, the condition "solution available but not proven optimal due to numerical difficulties" means that the solver is running into some numerical difficulties while trying to complete the solution of the problem. When a model has such problems, the numerical difficulties typically may occur in a rather random manner: some model runs may complete well while others don't.

See this thread on the ETSAP Forum for several options that can be used for troubleshooting "Solution available but not proven optimal due to numerical difficulties":

Nonetheless, getting rid of all dummy imports has in many cases proven to be the easiest and effective way of improving the numerical stability of large VEDA-TIMES models. Therefore, as the first thing to try I would suggest disabling the dummy imports (if you have enabled them):

* Disable dummy imports to improve numerical stability

Under VEDA, you can define these in any scenario file. Of course, disabling the dummy imports requires that your model is in fact feasible.

Forum Jump:

Users browsing this thread: 1 Guest(s)