Veda2.0 Released!

Help with user constraint

I'm trying to implement a version of the RFS where in 2010 125 PJ if advanced fuels are produced, in 2015 724 PJ if advanced fuels are produced, 2020 1976 PJ if advanced fuels are produced and in 2025 125 PJ if advanced fuels are produced. Also in 2010 1581 PJ if conventional fuels are produced, in 2015 1976 PJ if conventional fuels are produced, in 2020 1976 PJ if conventional fuels are produced and in in 2025 1976 PJ if conventional fuels are produced. I have attached the user constraint I tried to use, but is not working. I would appreciate any help possible. Thank you.

Attached Files Thumbnail(s)
I cannot see anything wrong in your ~UC_T table. In fact, I just tested an almost identical constraint myself, and it worked perfectly: The total production of the commodities included in the constraint was forced to be at least the amount defined by the UC_RHSTS.

Thus, for my part I can confirm that my constraint is working.

Maybe you could first explain what you mean by saying "but is not working"?  Are you saying that these constraints are not getting generated at all, or that they are not formulated as you expected, or something else? Can you see VAR_COMPRD reported for the commodities (CELETH, CELETHB, ...)?

Could you perhaps also post the *.DD file for the scenario where you define these two user constraints? And please describe the commodities involved: what type are they, and are they produced in all model regions? Seeing the *.RUN file and the QA_check.log might also be helpful for analysing your problem.
What I meant by not working is that the constraints do not seem to be getting generated at all. I'm still new to TIMES, how would I check VAR_COMPRD? Also, where can I find the .DD and .RUN , so that I can post them? I have attached the QA_Check file. The commodities are produced in all the regions. Thank you very for your help.    

Attached Files
.txt   QA_CHECK.txt (Size: 86.31 KB / Downloads: 3)
(31-05-2018, 11:55 PM)newbie1 Wrote: I'm still new to TIMES, how would I check VAR_COMPRD?
By looking at the VAR_Comprd results attribute in VEDA-BE.

(31-05-2018, 11:55 PM)newbie1 Wrote: Also, where can I find the .DD and .RUN , so that I can post them?
In the same VEDA-FE work folder as QA_Check.log. For example, if the Excel file for the scenario is Scen_RFS.xls , you should find the *.DD file named RFS.DD in the VEDA-FE work folder.  Please pack that file together with the *.RUN file for the case into a ZIP file and post the ZIP file here.
Thank you for the help. I have attached the files as Zip file.

Attached Files
.zip (Size: 5.11 KB / Downloads: 1)
You included the following DD file in the ZIP:  epaus9rt_16_1_2_ts.dd
But that file only contains the timeslice definition!  It is not the scenario file where you have the UC constraint defined.  Please post the *.DD file for that scenario file.

[EDIT:] Looking at the RUN file, possible candidates where the UC constraints might be, appear to be the following:


Are the constraints defined in one of these?  If so, please post that file.
Sorry about that. I have attached the correct file.

Attached Files
.zip (Size: 8.6 KB / Downloads: 1)
Ok thanks for the scenario file uc-biofuelssimple.dd.  However, the file you posted does not contain any trace of the constraints "Advanced" and "Conventional", which you showed earlier.  It contains only the following UC constraints:


Thus, it seems that either you posted the wrong file, or you have not imported the ~UC_T table you showed earlier into your model at all. What do you think?
Thank you so much for all your help. The file is correct, but ~UC_T doesn't seemed be getting imported. If it's okay to ask, what is the correct way to make sure that the ~UC_T is imported? What I've done so far is in the VEDA FE navigator, clicked on the scenario and the sync. This doesn't seem to work. Thanks again.
I am not an expert on VEDA (only on TIMES), but it should get imported by clicking Sync.
Do you get any import errors then? Maybe you could post the Excel file for the scenario here?
I have attached the excel file for the scenario. I was wondering if I have to define advanced and conventional in other places? I think that might be why it's not working. Thank you.

Attached Files
.xlsx   Scen_UC-BIOFUELSsimple.xlsx (Size: 243.82 KB / Downloads: 6)
Newbie1 Wrote:I was wondering if I have to define advanced and conventional in other places? I think that might be why it's not working.
No, I don't think so.  I tested importing your scenario file, and my VEDA-FE imported your "Advanced " and "Conventional " constraints well.  See the resulting DD file attached.

Thus, I am sorry but I cannot reproduce your problem here. But I can see that you are using some oldish version of VEDA-FE (you have no UC_N descriptions in the DD file), and so you could consider upgrading to see if that helps. The Kanors VEDA support team would probably also be able to easily tell the reason for your problem.

Attached Files
.zip (Size: 5.32 KB / Downloads: 2)
Thank you very much for all your help.

Forum Jump:

Users browsing this thread: 1 Guest(s)