Veda2.0 Released!

Microsoft JET Database Engine 2147217904

Hi Amit


A colleague installed TIMES VEDA in a new PC with windows 7 (German version). 

While we were trying to view results in VBE, the following error (from log file) has been reported.  Could you please help to fix it?




Version: 4.8.74
12.05.2011 14:16:35
Error in procedure frmSaveTable.SaveThisTable
Source = Microsoft JET Database Engine
Number = -2147217904
Description = Für mindestens einen erforderlichen Parameter wurde kein Wert angegeben.
Error Stack  : Register Later() : cmdView_Click -> Stage 6 : SaveTable(T_12.05.2011141227) -> Stage 3 : cmdSave_Click() -> Stage 6 : SaveThisTable() -> Stage 7
strSaveSQL: Insert Into [C:\VEDA\veda_be\databases\TIMES_DEMO\Veda_SnT.MDB;PWD=v].[Layout] ([QName],[AttributeDesc],[CommodityDesc],[ProcessDesc],[PeriodDesc],[RegionDesc],[VintageDesc],[TimeSliceDesc],[UserConstraintDesc],[ScenarioDesc],[CommoditySetDesc],[ProcessSetDesc],[CommoditySetTotal],[ProcessSetTotal],[AttributeTotal],[CommodityTotal],[ProcessTotal],[PeriodTotal],[RegionTotal],[VintageTotal],[TimeSliceTotal],[UserConstraintTotal],[ScenarioTotal],[NumberFormat],[HideZeros],[HideValuesCondition],[ConvertedUnits]) Values('demo', 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, '0.00', Falsch, '', '')

Maybe this error is due to your date format (, because I think the table name should not contain dots. That problem actually was already fixed, but the fix was not made into the release, only to a Beta version.  Perhaps you should either download that Beta or change your date format to the U.S style.

We did try the Beta version and it didn't work!
Can you try Antti's other suggestion (date format)?

OK, we’ll check the date format first.  I suspect it could also be due to handling of decimals with “,” in German vs. “.” in English.  Will update the outcomes!

Hello Kannan,
Can you send us the SNT database from Databases folder?

Now the problem is solved.  Smile

The problem was with the language settings and we’ve changed the language from German to English! Wink
For me, the date format problem, which was fixed in 4.8.7422 is now back, after upgrading to 4.8.75.
The temporary table names now again contain the date separators (dots), and that leads to the message "Invalid Table Name!" every time I try to view a new temporary table.

Why is that?  I would think it would have been a good idea to include the fix also in the Release, wouldn't it?

So I guess I have to roll back to 4.8.7422, or do you think that I should give up and consent to using the U.S. date format? Shocked

PS: This issue was originally reported and described here:

Apologies Antti; we will resolve this very soon.
Actually, this fix has only been in the beta version. I suggest you stay with the beta. Unlike what the version number suggests, the beta is still better than production.
We need feedback from one group of users before releasing beta as production.
Ok Amit, thanks for this information!
I got deluded by the version numbers....

It was a special situation... we needed to do a small bug fix for a special case in production version. Given our versioning system, this made production superior to beta. I guess we should have re-released beta with a new number...


I had the same issues of temporally table name.  But it was fixed when I started using the Beta version xxx.  Eventually I updated the VEDA to 4.3.39 and the same problem recurred. Though now I used to create new tables for temporary results, does moving to the beta version solve the temporary table name issues?



I could see a link to beta version in several posts?  Are they same link that directs to the latest beta version?  If not, where one can access the latest beta version?

It might be good to have the latest beta version in the model history section or so....

(12-05-2011, 09:19 AM)AKanudia Wrote: Can you try Antti's other suggestion (date format)?

I'm facing the same problem reported in this thread: -2147217904

The proposed solutions were not very useful. The default system language is already English. The format of the date in the temporary table names does not include any dots. I tried to change the system date format to the US style MM/dd/yyyy instead of dd/MM/yyyy, and it didn't help either.

I'm running VEDA 4.9.8 on Windows 10

Any suggestions?

Thanks in advance

Possibly Related Threads…
Thread Author Replies Views Last Post
  Accessing cost - EPAUS9rT database chandra 2 5,302 28-01-2020, 12:00 AM
Last Post: chandra
Sad VEDA-BE won't open database DAYANG 4 8,777 26-06-2018, 03:32 PM
Last Post: DAYANG
  Problem with database since installing new VEDA-BE DanWelsby 5 13,273 05-01-2018, 06:10 PM
Last Post: Antti-L
  VEDA-BE won't open database DAYANG 0 4,227 06-08-2017, 01:48 AM
Last Post: DAYANG
  Error saving database sara 5 10,582 07-03-2014, 12:00 AM
Last Post: sara
  VEDA_BE error "Microsoft JET Database Engine" Luis Dias 0 4,223 27-09-2011, 01:04 PM
Last Post: Luis Dias

Forum Jump:

Users browsing this thread: 1 Guest(s)