Veda2.0 Released!


Solution aborted due to resource limit
#1
Hello, sorry for disturbing. 
In the model i am runing for my master thesis, there is 2 scenarios where i am having the same error related to time limit and i do not really know why since this scenarios just have a small change regarding the other scenarios. 
here is the error: 
   
I am also uploading the lst file and runlog of this scenario, please if someone know show can this be solved i would really appreciate an answer.

.zip   master_thesis_ppa.zip (Size: 78.2 KB / Downloads: 3)
Reply
#2
Hello,

it seems that you reached the time limit, you can modify the value RESLIM in the run manager from 50000 to a bigger value.

Another solution is to deactivate the crossover which takes most of the time, barrier algorithm takes around 800s in your case. You will need to modify your cplex.opt.

Based on the computer you have you can change the Threads=7 to Threads=-1 in cplex.opt to use 15 out of the 16 threads you have. It will speed the barrier resolution time.

this documentation may be interesting for you: https://iea-etsap.org/webinar/CPLEX%20op...models.pdf

Victor
Reply
#3
(19-04-2024, 07:32 PM)VictorG Wrote: Hello,

it seems that you reached the time limit, you can modify the value RESLIM in the run manager from 50000 to a bigger value.

Another solution is to deactivate the crossover which takes most of the time, barrier algorithm takes around 800s in your case. You will need to modify your cplex.opt.

Based on the computer you have you can change the Threads=7 to Threads=-1 in cplex.opt to use 15 out of the 16 threads you have. It will speed the barrier resolution time.

this documentation may be interesting for you: https://iea-etsap.org/webinar/CPLEX%20op...models.pdf

Victor
Hello Victor, I do not understand the cplex.opt thing i should change. Where can i find that document? because in the pdf you have send me it does not explain what exactly to change and where
Reply
#4
Have you tried to increase RESLIM ? does it work ?

cplex.opt is related to solver options in the run manager: https://veda-documentation.readthedocs.i...definition
Reply
#5
(22-04-2024, 05:58 PM)VictorG Wrote: Have you tried to increase RESLIM ? does it work ?

cplex.opt is related to solver options in the run manager: https://veda-documentation.readthedocs.i...definition

No i have not tried. But how can i change that thing in the cplex.opt? because that just appear in the run manager. But how can i change the threads to -1??
Reply
#6
(22-04-2024, 05:58 PM)VictorG Wrote: Have you tried to increase RESLIM ? does it work ?

cplex.opt is related to solver options in the run manager: https://veda-documentation.readthedocs.i...definition

The thing is that i do not find where to change those threads from 7 to -1
Reply
#7
You can find opt files in 'Veda\Veda_models\my_model\AppData\SolverOptFiles' with the path adapted to your context.

Modifying the threads number will mostly speed up barrier phase but not the crossover so it won't probably solve your RESLIM problem
Reply
#8
(23-04-2024, 12:24 PM)VictorG Wrote: You can find opt files in 'Veda\Veda_models\my_model\AppData\SolverOptFiles' with the path adapted to your context.

Modifying the threads number will mostly speed up barrier phase but not the crossover so it won't probably solve your RESLIM problem

Thank you so much. Is strange because in my model i do not have CPLEX in the solver options:
   
Reply
#9
just modify BA121-7 then
Reply
#10
(23-04-2024, 01:03 PM)VictorG Wrote: just modify BA121-7 then

Hello Victor, 
Sorry for disturbing you again. But I increased my RESLIM to 90000 from 50000 and it still is not able to solve it. I have no idea why this may be happening, specially since this is just one scenario from 5 I have run and the others finished relatively fast. Do you find anything else I could do? Thank you so much

.zip   master_thesis_ppa.zip (Size: 96.28 KB / Downloads: 2)
Reply
#11
It is difficult to help without having a look at your model.

Based on your description, if you have a parent case that solves quickly then what you added in your variant scenario is probably responsible for this time solution increase. You should have a look on your modification.

Sometimes dummy imports are responsible of numerical issues. What you can do is go in veda in Tools>User options>Syncing options and you uncheck the four boxes. Then start from scratch, sync your model and run a case. If there is an infeasibility, the log will give you information of the elements of your model involved, based on this you can alter your model to remove it.

It is a bit of trial and error
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Errors when reading the solution - restart option Mahmoud 6 1,219 02-11-2023, 05:46 PM
Last Post: Mahmoud
  Comparison between Perfect Foresight and Myopia/Timestep-Solution Alexander Burkhardt 5 2,937 18-07-2022, 12:24 PM
Last Post: Alexander Burkhardt
  Resource interrupt clenox 0 873 23-01-2022, 01:12 AM
Last Post: clenox

Forum Jump:


Users browsing this thread: 1 Guest(s)