VedaSupport Forum
Microsoft JET Database Engine 2147217904 - Printable Version

+- VedaSupport Forum (https://forum.kanors-emr.org)
+-- Forum: VEDA Back End (https://forum.kanors-emr.org/forumdisplay.php?fid=3)
+--- Forum: Questions and Observations (https://forum.kanors-emr.org/forumdisplay.php?fid=11)
+--- Thread: Microsoft JET Database Engine 2147217904 (/showthread.php?tid=152)

Pages: 1 2


Microsoft JET Database Engine 2147217904 - Kannan - 12-05-2011

Hi Amit

 

A colleague installed TIMES VEDA in a new PC with windows 7 (German version). 

While we were trying to view results in VBE, the following error (from log file) has been reported.  Could you please help to fix it?

Thanks

Kannan

 

Version: 4.8.74
12.05.2011 14:16:35
Error in procedure frmSaveTable.SaveThisTable
Source = Microsoft JET Database Engine
Number = -2147217904
Description = Für mindestens einen erforderlichen Parameter wurde kein Wert angegeben.
Error Stack  : Register Later() : cmdView_Click -> Stage 6 : SaveTable(T_12.05.2011141227) -> Stage 3 : cmdSave_Click() -> Stage 6 : SaveThisTable() -> Stage 7
strSaveSQL: Insert Into [C:\VEDA\veda_be\databases\TIMES_DEMO\Veda_SnT.MDB;PWD=v].[Layout] ([QName],[AttributeDesc],[CommodityDesc],[ProcessDesc],[PeriodDesc],[RegionDesc],[VintageDesc],[TimeSliceDesc],[UserConstraintDesc],[ScenarioDesc],[CommoditySetDesc],[ProcessSetDesc],[CommoditySetTotal],[ProcessSetTotal],[AttributeTotal],[CommodityTotal],[ProcessTotal],[PeriodTotal],[RegionTotal],[VintageTotal],[TimeSliceTotal],[UserConstraintTotal],[ScenarioTotal],[NumberFormat],[HideZeros],[HideValuesCondition],[ConvertedUnits]) Values('demo', 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, Falsch, '0.00', Falsch, '', '')




Microsoft JET Database Engine 2147217904 - Antti-L - 12-05-2011

Maybe this error is due to your date format (dd.mm.yyyy), because I think the table name should not contain dots. That problem actually was already fixed, but the fix was not made into the release, only to a Beta version.  Perhaps you should either download that Beta or change your date format to the U.S style.




Microsoft JET Database Engine 2147217904 - Kannan - 12-05-2011

Antti
We did try the Beta version and it didn't work!



Microsoft JET Database Engine 2147217904 - AKanudia - 12-05-2011

Can you try Antti's other suggestion (date format)?


Microsoft JET Database Engine 2147217904 - Kannan - 12-05-2011

OK, we’ll check the date format first.  I suspect it could also be due to handling of decimals with “,” in German vs. “.” in English.  Will update the outcomes!




Microsoft JET Database Engine 2147217904 - Vikrant - 13-05-2011

Hello Kannan,
Can you send us the SNT database from Databases folder?



Microsoft JET Database Engine 2147217904 - Kannan - 13-05-2011

Now the problem is solved.  Smile

The problem was with the language settings and we’ve changed the language from German to English! Wink



Microsoft JET Database Engine 2147217904 - Antti-L - 13-05-2011

For me, the date format problem, which was fixed in 4.8.7422 is now back, after upgrading to 4.8.75.
The temporary table names now again contain the date separators (dots), and that leads to the message "Invalid Table Name!" every time I try to view a new temporary table.

Why is that?  I would think it would have been a good idea to include the fix also in the Release, wouldn't it?

So I guess I have to roll back to 4.8.7422, or do you think that I should give up and consent to using the U.S. date format? Shocked

PS: This issue was originally reported and described here:
http://forum.kanors-emr.org/showthread.php?tid=128






Microsoft JET Database Engine 2147217904 - AKanudia - 13-05-2011

Apologies Antti; we will resolve this very soon.


Microsoft JET Database Engine 2147217904 - AKanudia - 13-05-2011

Actually, this fix has only been in the beta version. I suggest you stay with the beta. Unlike what the version number suggests, the beta is still better than production.
We need feedback from one group of users before releasing beta as production.



Microsoft JET Database Engine 2147217904 - Antti-L - 13-05-2011

Ok Amit, thanks for this information!
I got deluded by the version numbers....

Antti



Microsoft JET Database Engine 2147217904 - AKanudia - 13-05-2011

It was a special situation... we needed to do a small bug fix for a special case in production version. Given our versioning system, this made production superior to beta. I guess we should have re-released beta with a new number...


Microsoft JET Database Engine 2147217904 - Kannan - 13-05-2011

Amit

I had the same issues of temporally table name.  But it was fixed when I started using the Beta version xxx.  Eventually I updated the VEDA to 4.3.39 and the same problem recurred. Though now I used to create new tables for temporary results, does moving to the beta version solve the temporary table name issues?

Thanks




Microsoft JET Database Engine 2147217904 - Kannan - 13-05-2011

I could see a link to beta version in several posts?  Are they same link that directs to the latest beta version?  If not, where one can access the latest beta version?

It might be good to have the latest beta version in the model history section or so....




RE: Microsoft JET Database Engine 2147217904 - Younis - 29-06-2017

(12-05-2011, 09:19 AM)AKanudia Wrote: Can you try Antti's other suggestion (date format)?
I'm facing the same problem reported in this thread: -2147217904 The proposed solutions were not very useful. The default system language is already English. The format of the date in the temporary table names does not include any dots. I tried to change the system date format to the US style MM/dd/yyyy instead of dd/MM/yyyy, and it didn't help either. I'm running VEDA 4.9.8 on Windows 10 Any suggestions? Thanks in advance