VedaSupport Forum
EQ_CAPACT infeasibility - Printable Version

+- VedaSupport Forum (https://forum.kanors-emr.org)
+-- Forum: VEDA 2.0 (https://forum.kanors-emr.org/forumdisplay.php?fid=19)
+--- Forum: Questions and Observations (https://forum.kanors-emr.org/forumdisplay.php?fid=20)
+--- Thread: EQ_CAPACT infeasibility (/showthread.php?tid=1321)



EQ_CAPACT infeasibility - Lukas Novak - 19-11-2023

Dear Forum, I have came across a problem with installing new capacity of photovoltaic powerplants. I tried to solve the problem with forcing the model to build certain capacity of these but as I did so, the model fell into infeasibility. The error message tells me that there is only one variable in conflict and this is the capacity that I forced to install. It also shows that - as I interpret it - there is TS level availability factor (zero) in conflict with annual availability factor (nonzero), which I don´t really understand because I made a specific table for it and defined the AF as nonzeros for each TS. Please take a look at the error log in the attachment. What I also found out, if I exclude the table with AF out of the model, the model becomes feasible. But I don´t know what is wrong with the table, the values are being red properly by VEDA as shown in the Items Detail component. Could you please confirm me, that I can define AF in this way? I include the "flawed table" in the attachment as well. Thank you, Lukas Novak


RE: EQ_CAPACT infeasibility - Antti-L - 19-11-2023

You have a lower bound for the ANNUAL utilization factor, which seems to be in conflict.  I would suggest to remove that lower bound, because your TS level availability factors are all fixed, and so the ANNUAL utilization factor is redundant anyway.


RE: EQ_CAPACT infeasibility - Lukas Novak - 19-11-2023

(19-11-2023, 01:32 AM)Antti-L Wrote: You have a lower bound for the ANNUAL utilization factor, which seems to be in conflict.  I would suggest to remove that lower bound, because your TS level availability factors are all fixed, and so the ANNUAL utilization factor is redundant anyway.
Thank you Antti, it really was the case. I deleted the AFA values for PV plants and now the model works fine. Have a great day! LN