Download the latest version of VEDA-FE (45834) and VEDA-BE (492018)

Veda Application Installation guide


G_CYCLE and Discrete Unit Commitment
#1
Hi Everyone, 

I apologize if this question are silly. I have a model with the following 288 time slices: 4 Seasons: Fall, Winter, Spring Summer; 3 Days of Week: Weekday, Saturday, Sunday; Hours of day: 1-24 which gives a total of 288 times slices. Is the correct value for G_CYCLE (DAYNITE)=1? 


When I activate the Discrete Unit Commitment and run the model, I get a GAMS compile error.  Model works without issues when Discrete Unit Commitment is turned off. The error message from the lst file: 

**** The following MIP errors were detected in model TIMES:
****  71 EQ_DSCNCAP is an undefined equation
****  71 EQ_DSCONE is an undefined equation
97257  $ABORT  "*** ERRORS IN GAMS COMPILE ***"

I was wondering if someone could provide some guidance on what I can do to fix the error? Thank you very much.
Reply
#2
Can you upload the .lst file in this post.
Reply
#3
Yes, please upload the *.LST file (zipped).

G_CYCLE should be left untouched if you don't know how to define it. The documentation explains that the default value of G_CYCLE(DAYNITE) is 365, which is also exactly what you should have: 365 daily cycles on the DAYNITE level in a year.
Reply
#4
Thank for your reply and information. I have attached the zipped lst file.


Attached Files
.zip   temp lst.zip (Size: 13.93 KB / Downloads: 2)
Reply
#5
Ok, you are using a very old version of TIMES: v4.2.7 (released in 2018).

Please update your TIMES, and the problem with the GAMS compile error should be resolved.

Download link here:  http://www.kanors-emr.org/download.php
Reply
#6
(03-03-2020, 08:29 PM)Antti-L Wrote: Ok, you are using a very old version of TIMES: v4.2.7 (released in 2018).

Please update your TIMES, and the problem with the GAMS compile error should be resolved.

Download link here:  http://www.kanors-emr.org/download.php


Thank you for the help. Updating TIMES helped get rid of some of the errors. I still get a domain violation error for G_CYCLE. I have attached a screenshot of the syssetting file and the zip of the lst file . Any help would be appreciated. Thank you.


Attached Files Thumbnail(s)
   

.zip   temp lst 2.zip (Size: 34.31 KB / Downloads: 1)
Reply
#7
As I said, the default value is 365, and so there is no need to define it. So not clear to me at all why would you want to overwrite it with the same value?

Anyway, I think the domain violation is related to a problem in your parameter specification.  I am not a VEDA expert, but looking at the VEDA-FE Attributes Master I can see that VEDA expects the timeslice level in the Other_Indexes column.  So, if I would need to define it myself, I would not try putting DAYNITE into the Timeslice column (timeslice levels are not timeslices), but I would try it in the Other_Indexes column. Maybe you try that and let us know if it works?
Reply
#8
(04-03-2020, 04:00 AM)Antti-L Wrote: As I said, the default value is 365, and so there is no need to define it. So not clear to me at all why would you want to overwrite it with the same value?

Anyway, I think the domain violation is related to a problem in your parameter specification.  I am not a VEDA expert, but looking at the VEDA-FE Attributes Master I can see that VEDA expects the timeslice level in the Other_Indexes column.  So, if I would need to define it myself, I would not try putting DAYNITE into the Timeslice column (timeslice levels are not timeslices), but I would try it in the Other_Indexes column. Maybe you try that and let us know if it works?


Your suggestion works. Thank you for all your help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)