Download latest Version of VEDA-FE 4.5.815.

Veda Application Installation guide


Two input commodities, different PCG
#1
Hello.

I'm trying to model carbon capture(CCS) in the power sector, where a certain percentage of ELCCO2 (of commodity group ENV) and ELC (NRG) are combined to produce CCSCO2 (ENV). Without defining the PCG of the process, the CCS process consumes only  ELCCO2 and produces nothing. Defining the PCG as ENVO produces CCSCO2 and consumes ELCCO2 but not ELC. I've tried all the permutations and combinations of PCGs but nothing seems to work. My files are attached. What am I doing wrong?

Thanks.


Attached Files
.xls   SubRES_NewTechs_REG.xls (Size: 36 KB / Downloads: 1)
.xls   SubRES_NewTechs_REG(2).xls (Size: 36.5 KB / Downloads: 2)
Reply
#2
The basic problem is that you are trying to define a share between NRG and ENV commodities. Shares can be only between commodities of the same TYPE.

one way is this: Comm-IN=ELCCO2; Comm-OUT=CCSCO2 and CCSCO2r (residual emisisons). share between the output commodities will define what share of CO2 is captured. EFF=1.

for energy consumption:
Comm-In-A=ELC (this is auxiliary input). INPUT coefficient of ELC will be per unit of ELCCO2 processed. PCG could be ELCCO2.

CCSCO2r should be added to the CO2 accounting for electricity sector.
Reply
#3
(27-11-2018, 10:19 PM)AKanudia Wrote: The basic problem is that you are trying to define a share between NRG and ENV commodities. Shares can be only between commodities of the same TYPE.

one way is this: Comm-IN=ELCCO2; Comm-OUT=CCSCO2 and CCSCO2r (residual emisisons). share between the output commodities will define what share of CO2 is captured. EFF=1.

for energy consumption:
Comm-In-A=ELC (this is auxiliary input). INPUT coefficient of ELC will be per unit of ELCCO2 processed. PCG could be ELCCO2.

CCSCO2r should be added to the CO2 accounting for electricity sector.

Thanks! I tried defining the input coefficient as NRG_ACT (wild guess) but it wouldn't sync ("Column ignored due to alien element"). I can't find anything appropriate that fits the bill from the attribute master table (tried a few parameters like UC_ACT+). Could you please suggest a way to define the input coefficient?
Reply
#4
(30-11-2018, 04:13 AM)ach Wrote: Could you please suggest a way to define the input coefficient?

Try using INPUT for an INPUT coefficient.  Smile
I had a quick look at your Excel files, and I can see you had been defining the Share-I~FX, Share-I~LO and Share-I~UP parameters in columns to the left of ~FI_T.  But as far as I know, all numeric columns must be to the right of ~FI_T. So, from that perspective (in addition to what Amit has already said) , I am not surprised that they did not work...
Reply
#5
in addition, you have ignored the comment in the first row of this sheet... sheet names must start with a sector name. and name of the SubRES and sheet makes me wonder if you are trying to create SubRES by region. the whole idea of SubRES is to not have to repeat structural and numerical declarations which remain unchanged across regions. any region-specific information can only come through SubRES
I have attached your file with some changes - highlighted in yellow. you need to put in a number for INPUT.


Attached Files
.xls   SubRES_NewTechs_REG-AK.xls (Size: 42.5 KB / Downloads: 8)
Reply
#6
In VEDA-FE menu - Advanced functions - Attribute Master will show you the list of TIMES attributes that are supported by VEDA. You can use the search box to shortlist and identify relevant attributes and look up their details in TIMES documentation.
Reply
#7
Thanks! For anyone facing a similar problem: in addition to the tips above, setting the PCG as ENVO and specifying exact Share-O~FX values did the trick for me.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)