Download the latest version of VEDA-FE (45819) and VEDA-BE (492010)

Veda Application Installation guide


Strange behavior of mining and import processes
#1
A problem has occurred with our mining and import processes. Previously, these processes worked fine, but they are now both consuming and producing energy commodities. Because of this feature, we are not able to produce/ import any commodity to the model. The model just uses dummy commodities.

Have anyone else experienced this? How can it be solved? Please see attached pictures for more details.


Attached Files Thumbnail(s)
       
Reply
#2
Post a screen shot of this process in Browse (TIMES view)
Reply
#3
(08-06-2018, 02:00 PM)AKanudia Wrote: Post a screen shot of this process in Browse (TIMES view)



Attached Files Thumbnail(s)
   
Reply
#4
I am not sure why this process doesn't work. Try removing the EFF parameter.

what you see in the RES view is normal. Mining processes "import" the commodities from an exogenous region MINRNW.
Reply
#5
I have tried many things and ended up in testing the same thing by developing a new model keeping everything same and it works fine this time.

But I am still not able to figure out the issue.


Attached Files Thumbnail(s)
           
Reply
#6
Hi,

I am having the same problem: MIN*, IMP* and EXP* processes have both input and output.

I re-imported the entire model from scratch, it then worked fine (i.e. MIN* and IMP* only had outputs, and EXP* only had inputs).

BUT after I imported trade-scenario-files ("ScenTrade__Trade_Links" and "ScenTrade_TRADE_PARAM")(made it possible to trade commodities between regions, but not the same kind of commodities as I had IMP*, EXP* and MIN*), the MIN*, IMP* and EXP* again had both inputs and outputs.

What am I doing wrong?

/Anna
Reply
#7
If I understand correctly, you get different results between:
1) Starting from scratch, and running the model; and
2) After that, re-importing trade-scenario-files, and running the model again.

Is that correct?  If so, then I think the model input DD files for some reason must be different between 1) and 2), which I think is indeed strange. By comparing the Data_only GDX files between 1) and 2) you should be able to see what is different (using the gdxdiff utility).  Let us know if you find out the crucial differences.
Reply
#8
Hi,

Yes, I think you describe it correct, with exception form that I am not running the model. I am using the "process master" to look at the processes.

1. Have problem with IMP*,MIN*, EXP* both having input and outputs (which I identify in the looking at the processes in the "Process Master")
2. I start from scratch re-importing parts by parts (1)BY-files, 2)SubRES files: The IMP*,MIN*, EXP* have either input our output (works fine)
3. I continue to import scenario files (some at a time): The IMP*,MIN*, EXP* have either input our output (works fine)
4. After import "ScenTrade__Trade_Links" and "ScenTrade_TRADE_PARAM": IMP*,MIN*, EXP* both having input and outputs

I am not so familiar with gdxdiff (where do I do this?)

All the best
Anna
Reply
#9
Anna, can you please run your model before and after reimporting trade files, and see if you get different results?

This might simply be because after you reimport trade files, the external regions (MINRNW/IMPEXP) also get topology entries and they start showing up in process master. one way to check that will be to select any particular model region on the process master form.
Reply
#10
I will do so (might take some time - a "meeting-day" today, but will try to manage in between).
/Anna
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)