Download the latest version of VEDA-FE (45824) and VEDA-BE (492012)

Veda Application Installation guide


start year with different period definition
#1
I have a problem with my model when running with different periods definition because of a lower bound on electricity heating in residential sector. The model is calibrated for 2005 and the new technologies for electric heating start in 2006. When I run the model with as milestone year 2005 (1year) 2006(2years) 2010(5years) ,everything goes fine but when I run with 2005 (2years) 2010(7years) I get an infeasibility because the new technologies donot seem to be available in the first period (looking at LIMROW) though 2006 is included . Now I can go easily around but it seems strange to me
Reply
#2
I remember a similar issue with the PET model. The model originally had the milestone years 2000, 2001, 2005 etc, and I wanted to remove the milestone year 2001.  However, after removing 2001, the interpolation option 15, which had been used for various UC_RHSxxx, ACT_BND and FLO_SHAR parameters, migrated all those bounds specified for 2001 to the year 2000. As a result, the model, of course, then became infeasible. But after changing those interpolation options from 15 to 5 the model worked fine again.

Perhaps the issue you are seeing is similar?  If so, it should be rather easy to change the interpolation options in VEDA-FE.
Reply
#3
I think it must be something like that but why is the technology starting in2006 (year included in the period 2005)  not available, there is no migration there?
Reply
#4
Well, if you have specified START=2006, it is so by definition.
START(r,p)=2006 is converted into the TIMES attribute PRC_NOFF(r,p,'BOH','2005').
This means that the process is assumed to be unavailable between BOH and 2005, inclusive.
So, you are explicitly prescribing that the technology should NOT be available in 2005.

As an aside, I don't understand why you would like the new technologies now be available already in the base year.  Because you have specified those START=2006 parameters, the new technologies were not supposed to be available in the Base year.

Nonetheless, if you really think that the new technologies should be available already in the Base year, you can add the setting G_OFFTHD('2000') = 1 into your run file (before the call for maindrv). That will change the meaning of PRC_NOFF, such that it will consider technologies unavailable in a period only if the full period is covered by the OFF range.
Reply
#5
I thought that as the first period covers 2005 and 2006, the technologies starting in 2006 would be available in this first period; As it is not like that I will manage differently
Reply
#6
Very good, but note that the Base Year is meant for calibrating the existing energy system. Therefore, normally the new technologies are, in fact, not supposed to be available in the Base Year. And I understood that that is what you originally assumed in your model.

Consequently, I don't understand the reason why you would now want to make the new technologies available in the first period, if you remove the milestone year 2006. All the activities in the first period are assumed to be equal to the activity in the Base Year, and so there should be no need for any investments into new capacity in the first period, even if it includes 2006.
Reply
#7
One more question for clarification: assuming I have a 20 year period 2030 2050 with as milestone year 2040, technologies starting into 2045 are not available in that period unless I use the OFF parameter
Reply
#8
Yes, according the original design in TIMES, PRC_NOFF considers the technology unavailable in a period whenever the milestone year of the period is inside the OFF range. But since version v3.0.1 you have been able to change the meaning of PRC_NOFF, such that it will consider a technology unavailable in a period only if the full period is covered by the OFF range.

You can change the meaning of PRC_NOFF by using the new parameter G_OFFTHD(y)=1, where y stands for the year, starting from which the interpretation should be changed. The year index was included in the parameter, because normally one would still not want to make any new technologies available in the first period, as it is used for the Base Year calibration.  Therefore, if your Base Year (first milestone year) is y1, you can specify G_OFFTHD(y1+1)=1, to change the meaning of PRC_NOFF for all subsequent periods. But, if you really want to make any new technologies with START=y1+1 available in the first period (containing the year y1+1), you can set G_OFFTHD(y1)=1.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)