Did not find GAMS name ERROR
#1
Dear all,
      After installing VEDA-FE and GAMS 24.4, a strange probelm appeared. The error is "Errors in input DATA/COMPILE", and many GAMS names can't be found. Attached is the ERROR picture, and I hope I can gain your help again.

Reply
#2
I tested demo 1, so the problem is caused by issues other than the model?
Reply
#3
 Anyone has ecountered this problem before? An error in input data/compile and a compilation error happened after I chose the solve button in VEDA-FE.  
Reply
#4

GAMS_SRC folder not found, check selected GAMS root path on Case Manager (F9).
Reply
#5
(21-10-2015, 08:24 PM)huichenpku Wrote:  Anyone has ecountered this problem before? An error in input data/compile and a compilation error happened after I chose the solve button in VEDA-FE.  


Hello I face this problem too. I have to have some error in the excel source file. If I use an older excel source file, this problem does not occur. Is any way how to find where is the error, please?
Reply
#6
Hi Lukas,

If you are facing similar GAMS issue then GAMS_SRC folder should be missing or empty.

Can you explain bit more about the excel file issue? and tell me the VEDA-FE version as well?

and you can post error log file also if you are getting any error message.
Reply
#7
Hi Vikrant,

my GAMS_SRC folder should be ok. The problem stems form one of my B-Y templates. I made some changes in the templates and obviously made some error. But I cannot find where.
If is use the old version of this B-Y template, it works fine.
I have the new version of VEDA-FE 4.5.5 but I faced this issue under under the previous versions too.
Which error log should I post?

Thank you!
Reply
#8
Those "Did not find GAMS name" errors appear also if you have some other GAMS compilation error (other than missing or empty GAMS_SRC folder).  Could you post the listing file (zipped), so that we can see the errors?
Reply
#9
Sure, where can I find it?
Reply
#10
The .lst file in the work folder under VEDA-FE, where you run the model (Gams_Wrk*).
Reply
#11
(29-11-2017, 04:00 PM)Antti-L Wrote: The .lst file in the work folder under VEDA-FE, where you run the model (Gams_Wrk*).


Here it is. Thank you!


Attached Files
.zip   pokus.zip (Size: 56.03 KB / Downloads: 4)
Reply
#12
Thanks Lukas.  
The listing file indicates that this clearly appears to be a bug in VEDA-FE.
I'll leave it to Vikrant to look after more closely...

[EDIT:] But you could try eliminating the errors yourself by removing all special characters from your process/commodity descriptions.
Reply
#13
(29-11-2017, 04:26 PM)Antti-L Wrote: Thanks Lukas.  
The listing file indicates that this clearly appears to be a bug in VEDA-FE.
I'll leave it to Vikrant to look after more closely...

[EDIT:] But you could try eliminating the errors yourself by removing all special characters from your process/commodity descriptions.


Thank you,
I found now the problem is in the technology description in ~FI_Process table. If I deleted all description, it works fine. Some description was maybe too long?
Reply
#14
Hi Lukas,

Can you post the base.dd(zipped)?
Reply
#15
(29-11-2017, 05:56 PM)Vikrant Wrote: Hi Lukas,

Can you post the base.dd(zipped)?

Hi Vikrant, here is the problematic table with process descriptions. Is it fine so?
Lukas


Attached Files
.xlsx   B-Y_process.xlsx (Size: 40.69 KB / Downloads: 5)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)